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In order to publish the data that’s in your database (other than as an intranet
or internet server), you need to export it from the database and put it into another
application, such as a page layout program, or to create certain types of text files
for use in other applications (such as web browsers).

There are two basic ways to export data: 
• Exporting via Export Style Sheets

This method uses the Export Style Sheets that you have designed to meet
the specific formatting requirements of your publications. Please refer to
Chapter 6 for information about Export Style Sheets.

• Using Quick Report to export data.
This is useful if you want to do a simple export of raw data to a delimited
text file. It is very fast, and easy to set up.

Exporting using Export Style Sheets
This is the method you will probably use most of the time to export your data.
When you have set up one or more Export Style Sheets (as explained in

Chapter 6), you can use them to create the text files that will comprise your publi-
cation. The steps involved in doing this are:

• Select the records to include in the publication.
• Select the Export Style Sheet to use 
• Export the data to a text file.
• Import the text file into another application
The procedure is explained in detail below.

Selecting records to export
When you set up your Export Style Sheets, each one was based on either the

Companies, Contacts, Products, or Categories table. Now  that you are ready to
export the data, you will first select the records that will comprise your publica-
tion from one of those tables.

This is what to do:
➢ At the main CatBase screen, choose either Companies, Products,

Contacts, or Categories from the Data menu (your tables may have differ-
ent names). Remember that if you want the data sorted by Category, you
should have designed an Export Style Sheet based on either Company
Categories or Product Categories, and now you should choose Categories
and not Companies or Products from the Data menu. This is because
CatBase will sort the Categories by name or number and will then search
for all the Company or Product records that belong to each Category. 

➢ At the Search Dialogue, click on All Records to include all records in the
table, or on Search Editor to search for selected records to include. You
might do this if, for example, you want to break the data down into sec-
tions. If there are a large number of records you might want to create a
separate file for each letter of the alphabet, or for each country, or for
each category. Use the Search Editor to search for the records you want
to export now. The Search Editor is explained in detail in Chapter Four,
Searching and Sorting.



➢ When a list of records is displayed, scan it to make sure you’ve got the
records you want to put into your publication, and then choose Export …
from the File menu.

Choosing the Export Style Sheet
The following dialogue box opens up:

If you are using CatBase Multi-User, it looks like this:
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The list on the left of this screen includes all Export Style Sheets that are
based on the table whose records you have selected. If an Export style Sheet
you have designed is not listed, that is probably because the Export Style Sheet
is based on a different table than the one from which you are trying to export
data. For example, you based it on Companies but you currently have a list of
Products displayed on your screen. Keep in mind that if an Export Style Sheet is
based on either Company Categories or Product Categories, you will need to
create a list of Categories from which to export data, not Companies or
Products. CatBase will find all the appropriate Company or Product records that
belong to each Category as the Categories are exported.

Export Format
The Export Format pop-up lists all possible exporting destinations. The

choices are:

Creates a tagged text file for  use with
PageMaker versions prior to 6.5.

PageMaker 6.5-

Creates a tagged text file for  use with
PageMaker version 6.5 or later. Can include
pictures.

PageMaker 6.5+

Creates a tagged text file which can be
interpreted by Multi-Ad Creator (Mac only).

Multi-Ad Creator2

Description
Creates a tagged text file which can be
interpreted and formatted by a web browser
such as Netscape Navigator or Internet
Explorer. Can include pictures.

Export Format Name
HTML

EXPORTING DATA

V 4.17 9.5



Each Export Style Sheet has a default Export Format selected, and this will be
selected on the Export Format pop-up when you click on an Export Style Sheet in
the list on the left of the window. However, you can select a different export for-
mat if you want. For example, you may have carefully set up an Export Style
Sheet to export your data to QuarkXPress, and then you find that you need to
export exactly the same information to a plain text file. No problem! Just select
Plain Text from the pop-up when you export the data.

Exporting in Multi-User
If you are using CatBase multi-user (the network version), the Export on: area

will be visible:

The Server radio button is always selected by default, and normally you
wouldn’t want to change this. When the data is exported on the server it is much

Creates a tagged text file for use with any
application that can interpret RTF tags. RTF
is a very widely-supported format; most
publishing and word processing programs
support it, for example:

Microsoft Word
PageMaker
PagePlus

RTF

Creates a tagged text file for use with
QuarkXPress. Can include pictures (XTags
Xtension required for pictures).

XPress 3.0 or 4.0

Creates a plain delimited text file. There is
no formatting information in the file. Each
field is separated by a specific delimiter (as
specified in the Export Style Sheet), and
each record is separated by another delim-
iter (usually a Return character).

Plain text files are useful for transferring raw
data from the database to another applica-
tion that is not a publishing destination – for
example, a spreadsheet.

Plain Text
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faster because all of the work of finding and formatting the information is done by
the server – there is no need for CatBase to copy data back and forth across the
network. You can start an export and then carry on working; CatBase will let you
know when the export is finished.

Exporting data
To begin the export:
➢ Select  the Export Style Sheet you want to use.
➢ Make sure that the correct Export Format is selected (it defaults to the

default Export Format that was selected for that Export Style Sheet).
Select a different Export Format if you wish.

➢ Click on OK.
You will be prompted to name the file that CatBase will create:

CatBase supplies a default name for the file. On Windows, the appropriate file
extension is included – for example, if you are exporting to a plain text file, the
default file name will be export.txt.

You can change  the file name, but be careful (Windows users) not to change
the file extension!

➢ Check where the file is going to be saved and select a different folder if
necessary. 
If you are using CatBase Multi-User, and the file is going to be exported on
the server, you can select a location on your own hard disk. The file will be
created on the server and then copied onto your hard disk when it’s fin-
ished.

➢ Click on Save.

CatBase exports the data and lets you know when it is finished.

Importing data into a page layout program
When CatBase has finished exporting the data, it will beep and tell you it’s

done. Your next step is to open up your publishing destination and import the
data into it.
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Publishing Destinations
If you are using a page layout program such as QuarkXPress or PageMaker,

you will probably have designed a template for your publication. If you haven’t,
this would be a good time to do that! The template should consist of the basic
specifications for the publication: the page size, number of columns, whether it’s
double-sided, default page headers and footers, etc. QuarkXPress users: If you
are using custom colours, H&Js,  etc., you should make sure that they are set up
in the template before you import the CatBase data.

Import Filters
If you are importing into a page layout program, you must make sure that you

have the correct import filter installed.
The following chart describes what’s needed for each type of publishing desti-

nation.

No special filters are required if the data
was exported specifically for this format.

Multi-Ad Creator2

An RTF filter will be needed. Please
check your program’s documentation.

Any program that can interpret
RTF tags

No special filters are required if the data
was exported specifically for this format.

PageMaker V. 6.5 or later

The RTF Import.flt filter must be installed
in the Aldus folder within your System
Folder. You can find this filter on one of your
PageMaker disks.

PageMaker versions before
6.5

Requirements
You MUST have the XPress Tags Filter or

the Xtags Xtension installed in the same
folder as your QuarkXPress program (or in
the Xtension folder within your QuarkXPress
folder). You MUST NOT have the Style Tags
Filter installed in the same folder! This will
definitely spoil your text formatting. (The
Style Tags filter is an old version of the
XPress Tags filter.) The XPress Tags Filter
can be found in your original XPress pro-
gram installer.

If you are going to import pictures or if
you have used style sheets that use text
boxes, you must have the XTags Xtension
installed in your Xtension folder.

Publishing Destination
QuarkXPress
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Importing the data:

1. Open up your document or template.
2. Choose Import Text ... from the File
menu
3. Locate the file you just exported from
CatBase and select it.
4. Select the Break Text radio button and
click on Place.
5. The Break Text window appears:

Multi-Ad Creator

1. Open up your document or template.
2. Choose Place ... from the File menu
3. Locate the file you just exported from
CatBase and select it.
4. Make sure the Read Tags check box is
selected.
5. Click OK.
6. Place the text on the page.

PageMaker version 6.5 or
later

1. Open up your document or template.
2. Choose Place ... from the File menu
3. Locate the file you just exported from
CatBase and double-click on it.
4. Place the text on the page.

PageMaker versions earlier
than 6.5

How to Import
1. Open up your document or template.
2. If your import includes pictures, and you are
using a template, you must save the document
before you import the data.
3. If you are not using the Xtags Xtension,
choose Get Text … from the File menu.
4. If you are using the Xtags Xtension, 
choose Get Text with XTags … from the File
menu. 
5. Locate the file you just created and click on
it ONCE.
6. Click in the Include Style Sheets
checkbox to select it. If the check box is dimmed,
you have not installed the appropriate import filter.
7. Click on Open or press the Enter key.

Publishing Destination
QuarkXPress
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1. Start your web browser (Netscape
Navigator or Internet Explorer, for example).
2. Drag and drop the file you just created onto
your web browser’s screen, or choose Open …
from the File menu and open it that way.

HTML Documents

7 Select the Apply Tags radio button in the
Format area.
8 Select the Make array of blocks radio
button, below the Break Text area.
9. Click on OK.

Your screen will probably look a bit different at first.
There are three important changes to make.
6. Select the At delimiter radio button in
the Break text area and enter [break] into the
text area. The Break Text area should look like
this:
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You might find that you’ll need to do a little “debugging” of your Export Style
Sheets. The easiest way to do this is to print out a few pages of the publication
and check to see if they are formatted exactly as you want. Mark up any discrep-
ancies you find and then go back to CatBase and make the necessary modifica-
tions to the style sheets and Export Style Sheet.

Making global formatting changes after importing
Sometimes you’ll want to make global style changes after the data have been

placed in your page layout template. No problem! If you are using a page layout
or word processing program, you will have Style Sheets set up – either ones that
you set up in the application, or that were created when the data was imported.
You can make global formatting changes in the publication by modifying the
Style Sheets. Here’s an example:

You created a Paragraph Style Sheet named Productname in CatBase; that
style sheet is used for the product names. When you look at the data after you
have imported it into your page layout template, you decide that you would like
to make the product names two points larger. You can modify the ProductName
style sheet, and the change will immediately be applied to all of the product
names in the publication.

Note for QuarkXPress users: If you have made a change to a stylesheet in
your CatBase database and you then import a file which uses that stylesheet into
a Quark document, the stylesheet changes will NOT be updated in the Quark
document if a stylesheet with the same name already exists in that document.
The stylesheets are only created if they do not already exist. You must either
make the same changes in the Quark style sheet, or delete any modified style
sheets from the Quark document; then they will be re-created when you import
the file.

Building Indexes
Indexing is supported by the following publishing destinations:

QuarkXPress (requires an Xtension)
PageMaker (V 6.5 or later)
RTF
HTML

To set up your data for indexing, all you need to do is tell CatBase which field
you want to index. This is done very easily by selecting the Index check box on
the appropriate Element screen in your Export Style Sheet:

1. Start the application that you want to use to
view or manipulate the data.
2. Open up the file you just created, usually by
choosing Open … from the File menu.

Plain Text Files
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(The Options area is located on the Preferences tab of the Element window.)
Please see Chapter Six for more information about Export Style Sheets.

The following table describes what’s needed for each publishing destination,
and how to create the indexes.

1. When you have finalised the layout of the
publication:
2. Choose Create Index … from the
Utilities menu. You’ll see a dialogue box like
this:

PageMaker 
Version 6.5 or later

What’s required/how to do it
1. You need to have a copy of an Xtension
called Indextension installed in your Xtension fold-
er.
When you have finalised the layout of the publica-
tion:
2. Position your cursor where you want the
index to go. If you are  going to create a separate
Index document, create a text box at the end of
your document and click inside it.
3. Choose Generate Index from the
Utilities menu. If this option is not visible, then
you have not installed the Indextenion Xtension.
You will find a demo version of Indextension on the
CatBase CD.
4. Indextension creates the index. 
If you have created your publication across several
Quark documents, you can build a complete index
in the following way:
1. Create the index, as described above, for
each document.
2. Create a separate document for the index.
3. Copy and paste the indexes form the vari-
ous documents into one text box in your Index
document.
4. Click in the text box and choose Manual
Index Sort from the Utilities menu.

Publishing Destination
QuarkXPress
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Creating Cross-Reference Indexes

If you set up the index preferences so that the page numbers are separated
from the index entries by a Tab, you now have a file that can be used to import
page numbers back into CatBase so that any number of cross-referenced index-
es can be built. For example, you can easily create an Export Style Sheet that
builds a “Companies and Products” index which lists each Company alphabeti-
cally, with each company’s products listed along with their page numbers. This is
how to do it:

1. Make sure you have a current backup of your database!
2. Save the index to a separate plain text file. For example, to do this in

QuarkXPress, click within the text box that contains the index. Make sure
that no text is selected. Then choose Save Text … from the File menu,
enter a file name, and click on Save. This creates a plain text file contain-
ing the index entries.

A separate HTML document, called index.html
(Mac) or index.htm (Windows) is created.

HTML

Check your application's documentation to find
out how to create the index. For example, if you
are using Microsoft Word Version 6:
1. Finalise the layout of the publication.
2. Choose Index and Tables … from the
Insert menu.

RTF

3. Make any necessary modifications to the
formatting of your index. Refer to your PageMaker
documentation for more information.
4. Click on OK.
PageMaker generates the index and loads it into
the cursor.
5. Click on the document in the place that you
want the index to go.
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3. In CatBase, choose a field to use for the page numbers. You could rename
your chosen field Page Number in the Table and Field Setup screen. Note
that the page number field can be either text or numeric; use a numeric
field if you want to be able to sort records by page number order. If there
is a chance that your index may contain multiple page numbers for any
entry, then you will need to choose a text field.

4. If you have imported page numbers into the database from a previous
publication, you will need to clear all the existing page numbers before
importing the current ones. You can easily do this using Search & Replace.

5. Create a new Import Format by choosing Import ... from the File menu.
6. Choose the appropriate radio button in the Import Table: area.
7. Select the “key” field from the pop-up list of fields. This is the field that

you indexed -- e.g., the Company or Product Name. Then click on Add to
Import Field List.

8. Select your page number field and click on Add to Import Field List.
The Import screen should now look something like this:

9. Click on the Select a File button. Locate the index file you saved as a
text file from your document and double-click on it. CatBase imports the
first five records and shows them in the Sample Import Text area -- check
this to make sure you’ve selected the correct fields.

10.Click on the Updates tab at the top of the screen. The Updates page
looks like this:
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11.Choose the Update Records radio button.
This tells CatBase that for each record it imports, it should look for a
matching record in the database by comparing the Key field. When it finds
a match, it will copy the page number into the specified page number
field.

12.Click on the Main tab, and then click on the Import Now button.

CatBase imports the file and updates the records with their page numbers.
13.Now you can build Export Style Sheets to create any cross-referenced

indexes you need.

A problem that can arise when you index company or product names is that
of duplicate names. This may be OK if it’s a case of the same entry appearing
more than once in the publication, but if they are different entries, you’ll have a
bit of a problem with your index, as it will think that they are the same entry. The
solution is to build the index on the record number field, which is unique for every
record. Of course this means that the record numbers will then appear in your
publication; however you can make them “invisible” by selecting special charac-
ter formatting for that Element -- make it very small and white so that it doesn’t
show up on the page. Then your index will consist of record numbers and page
numbers -- you can import the index back into the database as described above,
and then create an accurate index from the database.

Please contact the CatBase technical support team if you need help with
indexing.
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Exporting via Quick Report

You might need to export unformatted data from your CatBase database for
some use other than publication. This is easily accomplished via Quick Report,
and is explained in Chapter 5, Reporting. When you export data this way, you
create a tab-delimited text file (the field delimiter is a Tab character, and the
record delimiter is a Return character) which can be read by many other pro-
grams such as other databases, spreadsheets, and word processors.

Creating delimited text files in this way is quick and easy, but somewhat limit-
ed. You can also create delimited text files using Export Style Sheets, in which
case you have much more control over the content and formatting of the file. For
example, using an Export Style Sheet, you can perform calculations (such as
marking up or discounting prices), and you can use CatBase Formulas to deter-
mine which data to include. Please see Chapter 6 for more details.
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